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Overview
Creating a large text document (50 pages or more) should be done using a word processing 
program with style and template features that help maintain consistency throughout your 
document. By creating a template with customized styles, you can write large documents from 
beginning to end without the need to insert page breaks, resize graphics, or adjust fonts—and 
everything looks just as it was intended.

In this document, we will guide you through the process of creating a customized template using 
OpenOffice.org 3 Some topics will be covered in detail while others will refer you to the User 
Guide for more information. This document assumes you are already familiar with 
OpenOffice.org basics, however, even a beginner should be able to conquer some of the more 
complex tasks by frequently referring to the OpenOffice.org online User Guide and Help 
documentation.

Before You Begin
To help speed the process of creating large documents, we strongly suggest that you take the 
time to carefully plan and organize it in advance.  Some questions to consider: 

• What size and font do you want your headings and text to be?

•  Do you want headings to be numbered? 

• How do you want your headings aligned? Do you want each chapter to start on a new 
page? 

• Will the first line of each paragraph be indented? 

• Do you have footnotes? How do you want tables to look? 

• Will page numbering be sequential throughout the document? 

• Will your document have an index or appendices?

This is just a sampling of the questions you must answer before you begin creating your 
document. Taking the time to plan ahead can prevent problems from arising, saving you a lot of 
time and frustration in the long run.

Protecting Your Data
Frequent saving and backing up is a must when dealing with data that may have taken hours to 
generate. OpenOffice.org 3 offers several options to help keep your data safe.

Automatically Create a Backup Copy
1. From the Tools menu, select Options > Load/Save > General. 

2. Select Always create backup copy and click OK. 

Now, each time you save your document, the previous version of the document is saved to your 
backup directory.

Save AutoRecovery Information
This command saves the information necessary to restore the current document in case of a 
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crash.

1. From the Tools menu, select Options > Load/Save > General. 

2. Select Save AutoRecovery information every and select the time interval at which you 
want to automatically save. 

3. Click OK. 

Create Links to Objects
To further protect your data, you should create and save different data types separately. For 
example, an embedded object such as a graphic should be created and saved as a separate 
file. Rather than embedding the object into the document, you should place it as a linked object. 
This helps keep your objects safe and it helps reduce your file size. It also automatically updates 
itself in the document when changes are made to the original file.

Save Often
You should make it a point to save your work several times a day onto an external data medium, 
such as a CD or external hard drive. When doing so, be sure to keep more than just the last-
saved update as your hardware or software could already have written corrupted data onto the 
hard drive while otherwise working fine. Only when opened afresh after a completed work 
session will OpenOffice.org Writer greet you with the message that the file is corrupted and 
cannot be read anymore. 

Printing Your Document
With Writer you can print your files by just clicking the printer icon or by choosing print from the 
file menu. By using the print menu you can define exactly which elements of the document you 
want to print. Exporting the document to PDF is also a good strategy for printing, as PDF is an 
established standard.

 

Saving in PDF Format
A PDF file can be viewed and printed on any platform with the original formatting intact, provided 
that supporting software is installed. 

1. Click the Export Directly as PDF button on the Standard toolbar. 

2. Select where you want to save the PDF document. 

3. Type a name for the document and click Save.

Taking OpenOffice.org with You
To make it easy for you to work on your document wherever you are, a portable version of 
OpenOffice.org is available. This version of OpenOffice.org runs from a memory stick, so you 
don't need to worry about whether or not the computer you are working on has OpenOffice.org 
installed. For more information about the portable version of OpenOffice.org, visit: 
http://portableapps.com/apps/office/openoffice_portable

Creating large documents with OpenOffice.org Writer 7

http://portableapps.com/apps/office/openoffice_portable


Templates
A template is a document that contains specific formatting styles for text, graphics, tables, 
objects, etc. A template can be used as the basis for creating other documents. For example, 
you can define paragraph and character styles in a document, save the document as a 
template, and then use the template to create a new document with the same styles. Unless you 
specify otherwise, every new OpenOffice.org text document is based on the default template. In 
this document we will show you how to create your own customized template. OpenOffice.org 
now has a Template Repository, where you can find useful templates. You can also upload your 
personal templates there and help other OpenOffice.org users. For further information visit: 
http://templates.services.openoffice.org/

Planning Your Document
Before starting with the actual writing, you should experiment with a lot of dummy text to come 
up with a desired layout. Once you are satisfied with the overall look, you can translate your 
sample into an appropriate array of page, character, and paragraph styles and save it as a 
template file that can be used as the basis for each chapter of your document. If layout changes 
are desired when writing the actual document, you can make the appropriate changes to the 
template and next time a chapter is opened the changes to the template will be noted and you 
can accept or reject as required.

Page Styles
In most cases, a large document requires several different page structures. For example, the 
title page needs neither header nor footer. The Table of Contents, which may extend over more 
than one page, uses Roman page numbering. The actual body of the document uses Arabic 
page numbering and contains the chapter title in the header.

OpenOffice.org uses page styles to specify the layout of a page, including the page orientation, 
background, margins, headers, footers, and text columns. To change the layout of an individual 
page in a document, you must create and apply a custom page style to the page. 

Creating a New Page Style
Page styles are created using the Styles and Formatting feature.

1. From the Format menu, choose Styles and Formatting.

2. In the Styles and Formatting window, click the Page Styles icon. 

3. Right-click a page style and select New.

4. Type a name for your page style in the Name box.

5. Select which page style you want to use for the following page in the Next Style box. For 
example, if you want to use this page style for more than one page, select its name from 
the Next Style menu. If you want to apply this page style to just a single page, select 
your default page style from the Next Style menu. Whichever style you choose is the 
page style that will be used in all subsequent pages until you manually change the page 
style.

6. Use the tabs in the dialog box to set the remaining styles for the page.
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Applying a Page Style
The style for each page is indicated at the bottom of the page in the second box from the left on 
the Status Bar. In this case, the Left Page style is used. To change the style, simply right-click 
the style and select a new page style from the menu. Use this method cautiously, though, as it 
will change the page style for all of your pages.

If you need to apply a new page style while maintaining the page styles you have already 
applied, you must first insert a manual page break. This is particularly useful when applying your 
default page style after your Title and Table of Contents pages.

1. From the Insert menu, choose Manual Break.

2. Select Page break.

3. Select a page style from the Style menu and click OK.

Modifying a Page Style
You can modify a page style at any time. The easiest way is to double click the page style in the 
status bar. The Styles and Formatting window automatically displays for that page style. You can 
also press F11 to open the Styles and Formatting window, right-click the page style you wish to 
modify, and select Modify.
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Page Orientation
OpenOffice.org uses page styles to specify the orientation of the pages in a document. For 
example, to change the page orientation of one or more pages in a document from portrait to 
landscape in a document, you need to create a page style that uses the landscape orientation, 
and then apply the page style to the pages. 

1. Follow the instructions above for creating a new page style. 

2. On the Page tab, select Landscape as the orientation.

3. Click OK.

To insert the landscape page: 

1. Choose Insert > Manual Break at the appropriate location in the document.

2. Select the landscape page style from the Style drop down menu. 

At the end of the section requiring landscape orientation, another manual page break is needed 
and a new page style applied.

Page Numbering 
When creating large documents, it is standard to use different page numbering for certain page 
styles. For example, the Table of Contents pages are typically numbered with Roman numerals 
while the rest of the document uses Arabic numerals. 
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Numbering Formats
You can set the page numbering format by modifying the page style. You will need a separate 
page style for each page number format.

1. From the Format menu, choose Styles and Formatting.

2. Click the Page Styles icon at the top of the Styles and Formatting window.

3. Right-click the page style you wish to modify and select Modify.

4. Click the Page tab.

5. Under Layout Settings, select a Roman numeral style from the Format menu and click 
OK.

Resetting Page Numbers
If, at any point in the document you want page numbering to start anew again, it should always 
be done by inserting a manual page break. Changing the number using the Page Number field 
command will cause problems with Writer's page count mechanism when generating the Table 
of Contents.

1. From the Insert menu, choose Manual Break... > Page break. 

2. Select the page style you want to insert.

3. Check the Change page number box and enter the number at which you want the new 
page to begin. 
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4. Click OK. 

If the first page of the document is to have a page number other than 1 then the paragraph style 
of the first paragraph has to be accordingly adjusted.

1. Place the cursor into the first line of the paragraph and select Format > Paragraph.

2. Click the Text Flow tab.

3. Under the Breaks section, check Insert.

4. Check With Page Style and set the desired page style and page number.

5. Click OK.
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Text Layout
The layout of the text section of a page is defined on the Page tab in the Page Style window. 

1. From the Format menu, choose Styles and Formatting.

2.  Click the Page Styles icon at the top of the Styles and Formatting window.

3. Right-click the page style you wish to modify and select Modify.

4. Click the Page tab.

Note that under the heading Margins, only the text section is defined, headers and footers are 
placed into the margin areas. From the Page tab, you can also select the page layout: Right and 
Left, Mirrored, Only Right, or Only Left. If your document is to be organized like a book, you 
should select Mirrored. Unless it is a prescribed requirement, it is considerably easier to stick 
with a single-page layout as a double-page layout brings additional complexities.

Creating large documents with OpenOffice.org Writer 13
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Headers and Footers
Headers and footers are placed in the margin area of the page using the Header and Footer 
tabs in the Page Style window. The process is exactly the same whether you are setting a 
header or a footer. For an example, we will show you how to set the same footer that is used in 
this document. 

To achieve this look, you need a bottom margin of 0.79 inches with a footer for indicating the 
page number and documents name. You'll need spacing of 0.20 inches between the text layout 
and the footer. For flexibility, we'll set the size of the footer to automatically adjust depending on 
the font  size you use. 

1. Specify a bottom margin of 0.79 inches (see the Text Layout section for more detailed 
instructions). This sets a spacing of 0.79 inches between the bottom of the page and the 
bottom of the footer box.

2. Click the Footer tab.

3. Check the Footer on box.

4. If you are using a Mirrored page layout, be sure to uncheck the Same content left/right 
box.

5. Enter 0.20 in the Spacing field. This sets the spacing between the bottom of the text 
layout and the top of the footer box.

6. Check AutoFit height in the Height field. The height of the footer box will change to 
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exactly fit the font size you use in the footer.

7. Click OK.

Controlling Text Flow
The whole text flow of a document should be controlled through the Text body paragraph style or 
one of its successors.

1. From the Format menu, choose Styles and Formatting.

2. Click the Paragraph Styles icon at the top of the Styles and Formatting window.

3. Right-click the Text body style and select Modify.

4. Click the Text Flow tab.

5. Check the Automatic hyphenation box. This sets Writer to automatically hyphenate 
words rather than pushing a whole word to the next line.

6. Check the Orphan control box and select at least 2 lines from the drop-down menu. This 
prevents a single line of a paragraph from being placed at the start or end of a page. 
Setting orphan control to 2 lines ensures that at least 2 lines of a longer paragraph are 
placed at the bottom of a page. Otherwise, the paragraph starts at the next page.
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Paragraph Styles
The next few sections deal with manipulating paragraphs with paragraph styles. Paragraph 
styles in OpenOffice.org Writer are hierarchically organized. You can see the hierarchy of all 
paragraph styles if you select Hierarchical from the menu at the bottom of the Styles and 
Formatting window.
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You can see that all paragraph styles are based on paragraph style Default. This means all 
paragraph styles “inherit” the settings of paragraph style Default unless one or more settings 
have been modified in a particular paragraph style or in one of its parent paragraph styles. For 
example, assume the font of paragraph style Default is Times New Roman and the font of 
paragraph style Heading (the parent of all heading styles) has been set to Arial. If you now 
change the font of the (hierarchically topmost) paragraph style Default to Garamond, then this 
change is inherited by all paragraph styles that use the Times New Roman font. However, in all 
Heading paragraph styles, the font Arial is retained. 

Creating a New Paragraph Style
You will need to create a paragraph style for each type of text you want: text body, headings, 
footers, captions, etc. You do this using Paragraph Styles in the Styles and Formatting window.

1. From the Format menu, choose Styles and Formatting.

2. Click the Paragraph Styles icon at the top of the Styles and Formatting window.

3. Right-click a paragraph style for which you want to base your new style and select New.

4. Type a name for your new paragraph style.

5. Select a paragraph style you want to follow this style. For example, if you are creating a 
heading style, you most likely would want your text body style to be the next paragraph 
style.

6. Use the tabs in the dialog box to set the remaining paragraph styles.

7. Click OK.
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Figure 9: Hierarchical view of paragraph 
styles.



Modifying a Paragraph Style
If you want to change the font (or any other characteristic) of all heading styles (or whichever 
style you wish), then you simply make this change in the parent paragraph style Heading.

1. From the Format menu, choose Styles and Formatting. 

2. Click the Paragraph Styles icon at the top of the Styles and Formatting window.

3. Right-click the parent style you want to change and select Modify.

4. Use the tabs in the dialog box to make the appropriate changes.

5. Click OK.

A paragraph style can also be modified by placing the cursor in any paragraph with the desired 
paragraph style and selecting Edit paragraph style.

Numbered Headings
Using OpenOffice.org Writer you can automatically number all chapters and sections. To do this, 
each chapter has to be assigned one of the heading paragraph styles, Heading 1 to Heading 10 
with the appropriate numbering style applied. Furthermore you can define the outline level for 
each paragraph or paragraph style. This is very helpful when you create an appendix and use 
letters for the numbering.
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Creating a Numbered Heading Style

1. From the Format menu, choose Styles and Formatting.

2. Click the Paragraph Styles icon at the top of the Styles and Formatting window.

3. Right-click a paragraph style for which you want to base your new style and select New.

4. Type a name for your new paragraph style.

5. Select a paragraph style you want to follow this style. For example, if you are creating a 
heading style, you most likely would want your text body style to be the next paragraph 
style.

6. Click the Numbering tab.

7. Select a Numbering Style from the drop-down menu.

8. Click OK.
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Setting Outline Numbering for Headings
If you've created a custom numbered heading style, you will need to apply the outline numbering 
to the style so Writer know which outline level each custom head belongs with. For example if 
you created Head1, Head2, and Head3 styles with numbering, you will need to tell Writer to 
apply level 1 numbering to Head1 (I.e., 1 Heading), level 2 numbering to Head2 (I.e., 1.1 
Heading), etc.

1. From the Tools menu, select Outline Numbering.

2. On the Numbering tab, select a level and then select the heading that goes with that 
level.

3. Click OK.

Cloning a Heading 
Of course, there are introductions, literature lists, and appendices which are supposed to be 
treated as headings but either are not numbered at all or numbered in a different way. The 
solution for this problem is cloning a paragraph style. Let's say, for example, that the Introduction 
is to use the paragraph style Heading 1, but without numbering. 

1. Set the cursor into the paragraph Introduction and assign paragraph style Heading 1 to 
it with a doubleclick in the Styles and Formatting window.

2. Then click New Style from Selection icon in the top right corner of the Styles and 
Formatting window.
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3. Type a name for the new style (Heading 1 Without Numbering). Note that the new style 
is now a “child” of style Heading 1. Any modifications made to style Heading 1 will 
automatically be reflected in style Heading 1 Without Numbering.
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4. Right-click the Heading Without Numbering paragraph style and select Modify.

5. Click the  Outline & Numbering tab and select None from the Numbering Style drop-
down menu. Set the outline level to level 1 in order to see the unnumbered heading in 
the document's index.

6. Click OK.

Indenting the First Line of a Paragraph
Indenting the first line of a paragraph is standard practice. However, this is often a matter of 
personal taste, or there may be a standard set. 

1. From the Format menu, select Styles and Formatting.

2. Click the Paragraph Styles icon at the top of the Styles and Formatting window.

3. Right-click the paragraph style you want to modify and select Modify.

4. Click the Indents and Spacing tab.

5. De-select Automatic and enter the indent size in the First line box.

6. Click OK.

Another frequent practice is to indent, but not on the first paragraph after a heading or after an 
illustration. The best way to accomplish this is to clone the Text body style (see the Cloning a 
Heading section) and create a Text body indent style (see instructions above). For the Text body 
paragraph style, choose Text body indent as the Next style. Now, when you apply styles to a 
heading, the first paragraph following the heading will use the Text body style. All paragraphs 
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after the first one will use the Text body indent style.

Starting Each Chapter on a New Page
It's common practice to start each chapter on a new page. To do this, you need to set 
paragraph style Heading 1 (or whatever style you are using as your chapter head) to start on a 
new page. 

1. From the Format menu, choose Styles and Formatting.

2. Right click the paragraph style you want to modify and select Modify. You may need to 
click the Paragraph Styles icon to see all paragraph styles.

3. Click the Text Flow tab.

4. In the Breaks section, check Insert. Make sure Page is selected as the type and Before 
is selected as the position.

5. Click OK.

Character Styles
For highlighting names of authors or foreign-language phrases, italics can be used. However, a 
more efficient way is to apply character styles to format single characters or entire words and 
phrases. By applying character styles you can perform a more focused search for the 
information you are looking for. For example, rather than searching for all words or phrases in 
italics, you can search for the exact information you need, such as “author” or “foreign-language 
phrase”. Using character styles also enables you to easily modify the style at any time. This is 
particularly important if  towards the end of the document you decide you want to change the 
way you highlight certain text.

Creating a New Character Style
1. From the Format menu, choose Styles and Formatting.

2. Click the Character Styles icon at the top of the Styles and Formatting window.

3. Type a name for the style in the Name field and select the style you wish to link it with. If 
you do not wish to link to another style, choose None.

4. Use the tabs to select the styles you wish to apply to the character style and click OK.

Applying a Character Style
1. Select the character, word, or phrase to which you wish to apply the character style.

2. Open the Styles and Formatting window by pressing F11 or selecting Format > Styles 
and Formatting.

3. Click the Character Styles icon at the top of the Styles and Formatting window.

4. Double-click the style you wish to apply.
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Master Document
Thanks to the Master Document feature in OpenOffice.org Writer, a large document can be 
written chapter by chapter and, towards the end, joined into a big document. A Master Document 
incorporates each chapter of a book as an individual OpenOffice.org Writer file. Using a Master 
Document is usually not necessary as OpenOffice.org Writer is stable and powerful enough to 
manage large documents. A Master Document is more appropriate when a document has 
several authors, or where individual chapters are created separately and then must be 
incorporated into a complete work. Benefits of using a Master Document include:

● When you print a master document, the contents of all sub-documents, indexes, and 
any text that you entered are printed.

● You can create a table of contents and index in the master document for all of the sub-
documents.

For consistency, all documents in a Master Document should use the same template. Please 
note that the Master Document does not allow cross references beyond a sub-document. The 
master document also does not transfer or share the page, paragraph, etc, styles with the sub-
documents. Thus layout and formatting can only be controlled in the master document. If the 
document is not being edited by multiple authors  you may want to reconsider the use of the 
Master Document.

Creating a Master Document 
1. From the File menu, choose New > Master Document. 

2. The Navigator window opens with Text highlighted. Type an introduction or enter some 
text on the blank page. This ensures that after you edit an existing style in the Master 
Document you see a changed style when viewing the sub-documents.

3. Click and hold the Insert icon.

4. Choose File to insert an existing file as a sub-document.

5. Browse to locate the file you want to insert and click Insert.

6. Repeat steps 3-5 until you have inserted all sub-documents.

7. Close the Navigator window and save the file.
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Working in a Master Document
With the Master document open, you can use the Navigator for rearranging and editing all sub-
documents within the Master Document. Following are some of the tasks you can complete 
using the Master Document Navigator.

• To open a sub-document for editing, double-click the name of the sub-document in the 
Navigator.

• To remove a sub-document from the master document, right-click the sub-document in 
the Navigator list and select Delete. The sub-document file is not deleted from your 
computer, only the entry in the Navigator is removed.

• To add text to a master document, right-click an item in the Navigator list, and then 
choose Insert >Text. A text section is inserted before the selected item in the Master 
Document where you can type the text that you want. You cannot insert text next to an 
existing text entry in the Navigator.

• To reorder the sub-documents in a master document, drag a sub-document to a new 
location in the Navigator list. You can also select a sub-document in the list, and click 
the Move down or Move up icon.

• To add an index, such as a table of contents, right-click in the Navigator list, and then 
choose Insert > Index.

• To update an index in a Master Document, select the index in the Navigator and click 
the Update icon.
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Footnotes
Footnotes reference more information about a topic at the bottom of a page. OpenOffice.org 
Writer  automatically numbers the footnotes.

Customizing the Footnote Area
You can customize the size and appearance of the footnote area using page style settings.

1. From the Format menu, choose Styles and Formatting.

2. Click the Page Styles icon at the top of the Styles and Formatting window.

3. Right-click a page style to which you want to customize the footnote style and click 
Modify.

4. Click the Footnote tab.

5. Select your preferred settings. In general, you should set your footnote area not to 
exceed the page area. If you choose to set a maximum size for your footnote area you 
risk having Writer automatically push a footnote reference to the next page.  

6. Click OK.

Customizing Footnote Settings
You can customize how Writer numbers your footnotes, where footnotes appear in the document 
(at the end of each page or at the end of the document), and which paragraph style to use for 
the footnotes.

1. From the Tools menu, choose Footnotes.

2. Select the options you wish to apply to your footnote. 

3. Click OK.

Inserting a Footnote
1. Click in your document where you want to place the anchor of the note.

2. From the Insert menu, choose Footnote. 

3. In the Numbering section, select the format you want to use. If you are using automatic 
graphics captions and you chose to number the footnotes, footnotes will not 
automatically be updated when new footnotes are inserted. To work around this, you can 
use a special character instead of a number. Select the Character option and either type 
the character you want to use or click the browse button (...) and select the character 
that you want to use for the footnote.

4. In the Type are, select Footnote.

5. Click OK.

6. Type the note in the footnote area on your page.

To switch between footnotes and anchors, click the reference for either the note or the anchor.
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Appendices
In general, appendices are treated a bit differently than the main body of the document. For 
example, page numbering is usually different, numbering style for headings is usually different, 
and you need to set appendix entries to appear in the Table of Contents.

Chapter Numbering for Appendices
Numbering of pages in appendices is continual. However, chapter numbering is not included for 
appendices. This means you should apply the above-described trick of using paragraph style 
Heading 1 Without Numbering (see the Cloning a Heading section). Numbering of appendices is 
most conveniently done by using the number range as described below. 

1. Insert the word Appendix at the start of the appendix.

2. Change the paragraph style to Heading 1 Without Numbering.

3. From the Insert menu, choose Fields > Other.

4. Click the Variables tab.

5. In  the Type column, select Number Range.

6. In the Format column, select A B C and click OK.

7. Repeat for each Appendix.
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Listing Appendices in the Table of Contents
In order to have the appendix headings listed in the Table of Contents, every appendix heading 
has to be selected and registered. 

1. Place your cursor at the beginning of the appendix chapter heading.

2. From the Insert menu, choose Indexes and Tables > Entry.

3. Select Table of Contents from the Index menu.

4. Type a name in the Entry field.

5. Click Insert.

6. Click Close.

7. Repeat for each appendix chapter.
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Cross-referencing
Cross-references allow you to jump to specific text passages and objects in a single document. 
A cross-reference consists of a target and a reference that are inserted as fields in the 
document. You can cross-reference text and most objects in your document, such as graphics, 
drawing objects, OLE objects, and tables, as long as they have a caption. See Adding a Caption 
in the Graphics section of this document for instructions on how to add a caption to an object.

Inserting a cross-reference
1. In your document, place the cursor where you want the cross-reference to appear. 

2. If the Fields dialog is not open, click Insert > Cross Reference. On the References tab, 
in the Type list, click the type of item to be referenced, for example Heading, Figure, or 
Bookmark. You can leave this page open while you insert many cross-references. 

3. Click on the required item in the Selection list, which shows the bookmarks or 
references that have been defined. In the Format list, choose the type of reference 
required. Usually this will be Reference (to insert the full text of the heading or 
bookmark), Category and Number (to insert the word “Figure” or “Table” and its 
number), Numbering (to insert the figure or table number without the word “Figure” or 
“Table”), or Page (to insert the number of the page the referenced text is on). Click 
Insert. 
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Modifying a Cross-reference
1. Right-click in front of the cross-reference that you want to modify.

2. If you cannot see the field shading of the cross-reference, choose View > Field 
Shadings or press Ctrl+F8.

3. Choose Edit > Fields.

4. Set the options that you want.

5. Click OK.

Updating a Cross-reference
Cross-references will automatically update when the document is opened. You can manually 
update cross-references by pressing F9.
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Graphics
Working with graphics is a rather complex subject, therefore we will only cover topics related to 
inserting graphics into an OpenOffice.org Writer document.

Inserting Graphics
Individual graphics can be inserted by selecting Insert > Graphics > From File.

Note: Inserting graphics via OLE is not recommended. From the viewpoint of data security it is  
more meaningful to export the graphic from its originating application and link it to 
OpenOffice.org Writer. If data is to be updated, simply export the graphic again from its native 
application. Sometimes, of course, it is more convenient or even necessary to use OLE. In this 
case, back up your data! If possible, save data in its native format and into a separate folder.  
Also it would be prudent to save the actual OpenOffice.org Writer document in another format, 
for example, RTF, in order to have at least the text saved separately. Notice also that if an OLE 
object is scaled without opening the corresponding OLE application, then only the preview will  
be scaled, which can lead to some rather unpleasant results. Therefore, always open the OLE 
application before scaling.

Creating a Link to Graphics
Graphics should always be inserted as a link, rather than embedded. This helps ensure that the 
main document is kept slim, all the graphics are always up-to-date and, in the case of data 
corruption or loss of the main document, the graphics are stored separately and remain safe. 

1. From the Insert menu, select Picture > From File.

2. Browse to find the picture you want to insert.

3. Check the Link box and click Open to insert the picture. 
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Relocating Linked Graphics
Preferably, you should store graphics in a separate folder from your main document. If you want 
to reorganize your graphics on your hard drive, such as move them into a different folder, you 
can easily update the links.

1. From the Edit menu, select Links.

2. Select all links you need to update by holding down the Ctrl key and selecting the links.

3. Click Modify.

4. Browse and select the new directory.

5. Click  OK.

6. Click Close.
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Breaking Links
You can also break links if, for example, you want to send a copy of your document to a 
professor and want to make sure all graphics arrive correctly.

1. From the Edit menu, select Links.

2. Select all the links you wish to break.

3. Click Break Link.

4. Click Yes.

5. Repeat for all links you wish to break.

Creating a Gallery
If you have a large number of graphics to insert it may be beneficial to create a custom gallery 
from which you can drag and drop graphics as needed. 

1. From the Tools menu, choose Gallery.

2. Click the New Theme button.

3. On the General tab, type a name for the Gallery.

4. Click the Files tab.

5. Click Find Files.

6. Browse and select the folder where your graphics are stored, click OK. The file names 
of images in the selected folder are listed on the left side of the window.

7. Click Add All and wait for all images to be loaded into the Gallery.

8. Click OK.

The Gallery now displays with your images displayed in the Gallery window. Keep the Gallery 
window open and when you need to insert a graphic, simply drag and drop it into your document 
from the Gallery. 

Anchoring Graphics
If you insert a graphic via Insert > Graphics > From File..., it will be anchored to a paragraph. 
This means that the graphic is joined to this paragraph and will be moved with the paragraph, 
yet does not necessarily follow the paragraph. If, at the end of a page, there isn't enough space 
for the graphic, then text of the next paragraph is pulled up to fill the page and the graphic is 
placed at the top of the next page. Should that be undesirable, then the graphic should be 
anchored as character. To anchor the graphic as character is highly recommended. This makes 
it much easier to handle more than one image in a single paragraph. Images can also be 
anchored into an empty paragraph so that the paragraph orientation defines the positioning of 
the graphic.

1. Right-click the graphic.

2. Select Anchor > As Character. This places the graphic into an empty paragraph and 
prevents another paragraph from filling in space above it.
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Captions
You can add continuously numbered captions to graphics, tables, frames, and drawing objects. 
You can also edit the text and the number ranges for different types of captions.

Adding Captions
When you add a caption to a picture or to an object, the object and the caption text are placed 
together in a new frame. When you add a caption to a table, the caption text is inserted as a 
paragraph next to the table. When you add a caption to a frame, the caption text is added to the 
text inside the frame, either before or after the existing text.

1. Select the item that you want to add a caption to.

2. From the Insert menu, choose Caption.

3. Type a name for the caption in the empty box at the top of the window.

4. Select a caption category.

5. Click OK.

A caption is formatted with the paragraph style that matches the name of the caption. For 
example, if you choose Figure for your caption category, the paragraph style used is called 
Figure. You can modify the paragraph style as needed. 

Note: OpenOffice.org can automatically add a caption when you insert an object, graphic,  
frame, or table. Choose Insert > Caption > AutoCaption. Select the options you want and click 
OK. A disadvantage of automatically-generated captions is that no footnotes can be 
incorporated. If that is a requirement, it is probably best to insert captions manually as you add 
each graphic.

Moving and Editing Captions
To move both the object and the caption, drag the frame that contains both items. Press F9 to 
update the caption numbering after you move the frame into place.

You can edit the caption text directly in the document just as you would any other text.
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Formulas
Because OpenOffice.org is a fully integrated productivity suite, you can insert and edit formulas 
(using OpenOffice.org Math) in your text document.

Inserting Formula Calculations
You can insert a formula in any text or table area of your document.

1. Place your cursor where you want to insert the formula.

2. Press F2 to display the Formula Bar.

3. Type your formula in the Formula Bar. To specify a range of cells in a table, select the 
desired cells with the mouse. The corresponding cell references also appear in the input 
line. 

4. Click Apply to confirm the entry (the green check mark next to the Formula Bar).

5. The calculation displays in your document.

Inserting Formulas in Symbolic Format
OpenOffice.org Math is used for writing equations in symbolic format. To activate OpenOffice.org 
Math, select Insert > Object > Formula. The OpenOffice.org Math Equation Editor opens. For 
step-by-step instructions on using Equation Editor, see the Getting Started with Math guide at: 
http://documentation.openoffice.org/manuals/oooauthors2/0111GS-GettingStartedWithMath.pdf
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Charts
OpenOffice.org 3 Writer includes a powerful chart tool. You can add and modify a variety of 
charts to meet your needs.

Creating a Chart
1. From the Insert menu, choose Object > Chart.

2. Right-click the chart and select Chart Data Table.

3. Enter the appropriate data in the chart. Use the buttons at the top of the chart to move 
data within the chart and to add or delete columns and rows as needed.

4. Close the Chart Data Table window.

Changing the Chart Type
OpenOffice.org provides a variety of chart types for you to choose from.

1. Double-click the chart until a gray border displays.

2. Right-click the chart and select Chart Type.

3. Select the type of chart you want and click OK.

Changing Chart Colors
You can easily customize the colors used in any chart type.

1. In the chart, double-click the color you wish to change.

2. On the Area tab, select the color you want.

3. Click OK.

Changing Text Style
You can also modify the fonts used on the chart.

1. Double-click the chart.

2. Click the Characters tab.

3. Select the font style attributes you wish to apply.

4. Click OK.

Customizing Your Charts
OpenOffice.org 3 offers many new features to help you customize your charts. For a list of new 
features and how to apply them to your charts, see 
http://blogs.sun.com/GullFOSS/entry/new_chart_features_in_openoffice1 
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Tables
If your document needs to contain a large number of tables, you should create a custom table 
format so all of your tables have the same formatting. When creating your template table, the 
layout will more easily be accepted if you use a table with several rows and columns.

For this section we will assume you already know the basics of inserting and formatting a table.

Creating a Table Format 
Use this process to add a new table style to the list of table formats.

1. Format a table in your document.

2. Select the table, and then choose Table > AutoFormat.

3. Click Add.

4. In the Add AutoFormat dialog, enter a name for your table format.

5. Click OK.

Applying a Table Format
1. Click in a table cell in a table you want to format.

2. Choose Table > AutoFormat.

3. Select the format that you to want to apply.

4. Click OK.
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Marginalia
 If you want to use Marginalia, you can do so with text frames, as shown in the example on the 
left. 

1. From the Insert menu, choose Frame.

2. Select the size, anchor, and position of the frame and click OK. If you have a two-sided 
layout, the marginalia must be placed on the outer page margin with the frame anchored 
to the paragraph.

3. Drag the newly placed frame to resize as needed.

If you want to insert another marginalia somewhere else in your text, simply copy the existing 
one.  

Note: Marginalia can also be generated and modified via paragraph styles or frame styles. A 
paragraph based on a paragraph style with marginalia has a left margin of 4 cm. You have to 
use a marginalia text frame in conjunction with this paragraph. The marginalia always appears 
on the left when using this method.
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Indexes
Creating an index is a multi-step process. First, you need to create index entries for each word 
or words you want included in the index. Then, you need to generate the index. Finally, you 
format the index.

Creating Index Entries
1. Click in a word, or select the words in your document that you want to use as an index 

entry.

2. From the Insert menu, choose Indexes and Tables > Entry, and do one of the following:

• To change the text that appears in the index, type the text that you want in the Entry box. 
The text that you type here does not replace the selected text in the document.

• To add an index mark to similar words in your document, select Apply to all similar texts.

• To add the entries to a custom index, click the New User-defined Index icon, enter the 
name of the index.

3. Click OK.

Editing and Deleting Index Entries
Index entries are inserted as fields into your document. To view fields in your document, choose 
View and ensure that Field Shadings is selected. 

1. Place the cursor immediately in front of the index entry in your document.

2. Choose Edit > Index Entry, and do one of the following: 

• To change the entry, enter different text in the Entry box.

• To remove the entry, click Delete.

To cycle through the index entries in your document, click the next or the previous arrows in the 
Edit Index Entry window. 

Generating an Index
1. Click in your document where you want to insert the index.

2. From the Insert menu, choose Indexes and Tables > Indexes and Tables.

3. On the Index/Table tab, select "Alphabetical Index" in the Type box.

4. Set the formatting options for the index, either on the current tab, or on any of the other 
tabs of this dialog. For example, if you want to use single letter headings in your index, 
click the Entries tab, and then select Alphabetical delimiter. To change the formatting of 
levels in the index, click the Styles tab. 

5. Click OK.

To update the index, right-click in the index, and select Update Index/Table.
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Formatting Index Entries
1. Right-click in the index and select Edit Index/Table.

2. Click the Styles tab.

3. Click an index level in the Levels list.

4. Click the style that you want to apply in the Paragraph Style list.

5. Click the assign button.

6. Click OK.
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Bibliographies
A small bibliography can be typed directly into the text of the document, but as the bibliography 
gets larger, more flexibility is obtained by using the database method. The OpenOffice.org Writer 
Help and the User Guide both give instructions on making a bibliographic database, and on 
using this database in the document. 

To help you manage your bibliographic entries, the following reference managers integrate with 
OpenOffice.org:

• Endnote

• Zotero

• Citavi

• Bibius 

42 Creating large documents with OpenOffice.org Writer



Creating a Table of Contents
By default, Writer will generate a Table of Contents based on Heading 1 – Heading 10 styles. 
You can customize the Table of Contents however you want...from the paragraph styles used to 
generate the contents to the formatting of the text.

Generating a Table of Contents
1. Place the cursor at the location in the document where you want the Table of Contents 

to start.

2. From the Insert menu, choose Indexes and Tables > Indexes and Tables.

3. On the Index/Table tab, enter a title (this will be the heading that displays on the Table of 
Contents page) and select Table of Contents from the Type menu.

4. Select how many levels you want to display in your Table of Contents. Typically, 3-4 
levels is sufficient, depending on how many levels of headings you use in your 
document.

5. Check the Outline and Index boxes and click the [...] button next to Outline.

6. This is where you map your levels to your paragraph styles. For example, if you use a 
Heading 1 and a Heading 1 Without Numbering, you need to make sure that both 
headings are mapped to Level 1. You do this by selecting 1 in the Level column and 
then selecting the paragraph style in the Paragraph Style menu. Writer automatically 
maps Heading 1 – Heading 10 to the appropriate level, but you will need to map each 
custom head you have applied in the document and wish to display in the Table of 
Contents.

7. By default, the Table of Contents will have a gray background, because it is wrapped in 
a read-only section. The gray background will not be printed. Anyway it is possible to 
disable the read-only mode in the index dialog. You can change the color of the 
background by clicking the Background tab and selecting a color.

8. Click OK. 

Note: Unfortunately, the page number formats of the various page styles are not automatically 
adopted by the Table of Contents. This means that anomalies in the Table of Contents, arising 
from this cause will have to be corrected manually. Be sure to un-check the Protect against  
manual changes box to enable the ability to make manual changes to the table.
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Editing a Table of Contents
1. Right-click anywhere in the Table of Contents and select Edit Index/Table.

2. Make changes as necessary.

3. Click OK to re-generate the table.

Formatting Entries
1. Right-click the entry you wish to format and select Edit Paragraph Style.

2. Make the appropriate changes to the paragraph style.

3. Click OK. Because you changed a paragraph style, all entries that use the same style 
will automatically update.

Updating the Table of Contents
Right-click anywhere in the Table of Contents and select Update Index/Table.

Deleting the Table of Contents
Right-click anywhere in the Table of Contents and select Delete Index/Table.
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Resources
There are many resources available to help you maximum your productivity and get the most 
from your OpenOffice.org suite.

Support and Documentation
• Writer Guide: 

http://documentation.openoffice.org/manuals/oooauthors2/0200WG-
WriterGuide.pdf

• Help: From the Help menu, choose OpenOffice.org Help (or press F1).

• Support: http://support.openoffice.org/

Extensions
To help make your life a little easier, there are many extensions (or plug-ins) available to extend 
the features of OpenOffice.org. You can view and download extensions from: 
http://extensions.services.openoffice.org/most_pop_ext

Additional Resources 
LaTeX is a document preparation system for high-quality typesetting. It is most often used for 
medium-to-large technical or scientific documents but it can be used for almost any form of 
publishing. You can learn more about LaTeX at: http://www.latex-
project.org/intro.html
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Public Documentation License, Version 1.0

1.0 DEFINITIONS.

1.1. "Commercial Use" means distribution or otherwise 
making the Documentation available to a third party.

1.2. "Contributor" means a person or entity who creates or 
contributes to the creation of Modifications.

1.3. "Documentation" means the Original Documentation 
or Modifications or the combination of the Original 
Documentation and Modifications, in each case including 
portions thereof.

1.4. "Electronic Distribution Mechanism" means a 
mechanism generally accepted for the electronic transfer 
of data.

1.5. "Initial Writer" means the individual or entity identified 
as the Initial Writer in the notice required by the Appendix.

1.6. "Larger Work" means a work which combines 
Documentation or portions thereof with documentation or 
other writings not governed by the terms of this License.

1.7. "License" means this document.

1.8. "Modifications" means any addition to or deletion from 
the substance or structure of either the Original 
Documentation or any previous Modifications, such as a 
translation, abridgment, condensation, or any other form in 
which the Original Documentation or previous 
Modifications may be recast, transformed or adapted. A 
work consisting of editorial revisions, annotations, 
elaborations, and other modifications which, as a whole 
represent an original work of authorship, is a Modification. 
For example, when Documentation is released as a series 
of documents, a Modification is:

A. Any addition to or deletion from the contents of the 
Original Documentation or previous Modifications.

B. Any new documentation that contains any part of the 
Original Documentation or previous Modifications.

1.9. "Original Documentation" means documentation 
described as Original Documentation in the notice 
required by the Appendix, and which, at the time of its 
release under this License is not already Documentation 
governed by this License.

1.10. "Editable Form" means the preferred form of the 
Documentation for making Modifications to it. The 
Documentation can be in an electronic, compressed or 
archival form, provided the appropriate decompression or 
dearchiving software is widely available for no charge.

1.11. "You" (or "Your") means an individual or a legal entity 
exercising rights under, and complying with all of the terms 
of this License or a future version of this License issued 
under Section 5.0 ("Versions of the License"). For legal 
entities, "You" includes any entity which controls, is 
controlled by, or is under common control with You. For 
purposes of this definition, "control" means (a) the power, 
direct or indirect, to cause the direction or management of 
such entity, whether by contract or otherwise, or (b) 
ownership of more than fifty percent (50%) of the 
outstanding shares or beneficial ownership of such entity.

2.0 LICENSE GRANTS.

2.1 Initial Writer Grant. 

The Initial Writer hereby grants 

You a world-wide, royalty-free, non-exclusive license to 
use, reproduce, prepare Modifications of, compile, 
publicly perform, publicly display, demonstrate, market, 
disclose and distribute the Documentation in any form, 
on any media or via any Electronic Distribution 
Mechanism or other method now known or later 
discovered, and to sublicense the foregoing rights to 
third parties through multiple tiers of sublicensees in 
accordance with the terms of this License. 

The license rights granted in this Section 2.1 ("Initial 
Writer Grant") are effective on the date Initial Writer first 
distributes Original Documentation under the terms of 
this License.

2.2. Contributor Grant.

Each Contributor hereby grants You a world-wide, 
royalty-free, non-exclusive license to use, reproduce, 
prepare Modifications of, compile, publicly perform, 
publicly display, demonstrate, market, disclose and 
distribute the Documentation in any form, on any media 
or via any Electronic Distribution Mechanism or other 
method now known or later discovered, and to 
sublicense the foregoing rights to third parties through 
multiple tiers of sublicensees in accordance with the 
terms of this License.

The license rights granted in this Section 2.2 
("Contributor Grant") are effective on the date 
Contributor first makes Commercial Use of the 
Documentation.

3.0 DISTRIBUTION OBLIGATIONS.

3.1. Application of License.

The Modifications which You create or to which You 
contribute are governed by the terms of this License, 
including without limitation Section 2.2 ("Contributor 
Grant"). The Documentation may be distributed only 
under the terms of this License or a future version of this 
License released in accordance with Section 5.0 
("Versions of the License"), and You must include a copy 
of this License with every copy of the Documentation 
You distribute. You may not offer or impose any terms 
that alter or restrict the applicable version of this License 
or the recipients' rights hereunder. However, You may 
include an additional document offering the additional 
rights described in Section

3.5 ("Required Notices").

3.2. Availability of Documentation.

Any Modification which You create or to which You 
contribute must be made available publicly in Editable 
Form under the terms of this License via a fixed medium 
or an accepted Electronic Distribution Mechanism.

3.3. Description of Modifications.
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All Documentation to which You contribute must identify 
the changes You made to create that Documentation and 
the date of any change. You must include a prominent 
statement that the Modification is derived, directly or 
indirectly, from Original Documentation provided by the 
Initial Writer and include the name of the Initial Writer in 
the Documentation or via an electronic link that describes 
the origin or ownership of the Documentation. The 
foregoing change documentation may be created by using 
an electronic program that automatically tracks changes to 
the Documentation, and such changes must be available 
publicly for at least five years following release of the 
changed Documentation.

3.4. Intellectual Property Matters.

Contributor represents that Contributor believes that 
Contributor's Modifications are Contributor's original 
creation(s) and/or Contributor has sufficient rights to grant 
the rights conveyed by this License.

3.5. Required Notices.

You must duplicate the notice in the Appendix in each file 
of the Documentation. If it is not possible to put such 
notice in a particular Documentation file due to its 
structure, then You must include such notice in a location 
(such as a relevant directory) where a reader would be 
likely to look for such a notice, for example, via a hyperlink 
in each file of the Documentation that takes the reader to a 
page that describes the origin and ownership of the 
Documentation. If You created one or more Modification(s) 
You may add your name as a Contributor to the notice 
described in the Appendix.

You must also duplicate this License in any 
Documentation file (or with a hyperlink in each file of the 
Documentation) where You describe recipients' rights or 
ownership rights. You may choose to offer, and to charge 
a fee for, warranty, support, indemnity or liability 
obligations to one or more recipients of Documentation. 
However, You may do so only on Your own behalf, and not 
on behalf of the Initial Writer or any Contributor. You must 
make it absolutely clear than any such warranty, support, 
indemnity or liability obligation is offered by You alone, and 
You hereby agree to indemnify the Initial Writer and every 
Contributor for any liability incurred by the Initial Writer or 
such Contributor as a result of warranty, support, 
indemnity or liability terms You offer.

3.6. Larger Works.

You may create a Larger Work by combining 
Documentation with other documents not governed by the 
terms of this License and distribute the Larger Work as a 
single product. In such a case, You must make sure the 
requirements of this License are fulfilled for the 
Documentation.

4.0 APPLICATION OF THIS LICENSE.

This License applies to Documentation to which the Initial 
Writer has attached this License and the notice in the 
Appendix.

5.0 VERSIONS OF THE LICENSE.

5.1. New Versions.

Initial Writer may publish revised and/or new versions of 
the License from time to time. Each version will be given a 
distinguishing version number.

5.2. Effect of New Versions.

Once Documentation has been published under a 
particular version of the License, You may always 
continue to use it under the terms of that version. You 
may also choose to use such Documentation under the 
terms of any subsequent version of the License 
published by______________________ [Insert name of 
the foundation, company, Initial Writer, or whoever may 
modify this License]. No one other than 
________________________[Insert name of the 
foundation, company, Initial Writer, or whoever may 
modify this License] has the right to modify the terms of 
this License. Filling in the name of the Initial Writer, 
Original Documentation or Contributor in the notice 
described in the Appendix shall not be deemed to be 
Modifications of this License.

6.0 DISCLAIMER OF WARRANTY.

DOCUMENTATION IS PROVIDED UNDER THIS 
LICENSE ON AN "AS IS'' BASIS, WITHOUT 
WARRANTY OF ANY KIND, EITHER EXPRESSED OR 
IMPLIED, INCLUDING, WITHOUT LIMITATION, 
WARRANTIES THAT THE DOCUMENTATION IS FREE 
OF DEFECTS, MERCHANTABLE, FIT FOR A 
PARTICULAR PURPOSE OR NON-INFRINGING. THE 
ENTIRE RISK AS TO THE QUALITY, ACCURACY, AND 
PERFORMANCE OF THE DOCUMENTATION IS WITH 
YOU. SHOULD ANY DOCUMENTATION PROVE 
DEFECTIVE IN ANY RESPECT, YOU (NOT THE 
INITIAL WRITER OR ANY OTHER CONTRIBUTOR) 
ASSUME THE COST OF ANY NECESSARY 
SERVICING, REPAIR OR CORRECTION. THIS 
DISCLAIMER OF WARRANTY CONSTITUTES AN 
ESSENTIAL PART OF THIS LICENSE. NO USE OF 
ANY DOCUMENTATION IS AUTHORIZED 
HEREUNDER EXCEPT UNDER THIS DISCLAIMER.

7.0 TERMINATION.

This License and the rights granted hereunder will 
terminate automatically if You fail to comply with terms 
herein and fail to cure such breach within 30 days of 
becoming aware of the breach. All sublicenses to the 
Documentation which are properly granted shall survive 
any termination of this License. Provisions which, by 
their nature, must remain in effect beyond the 
termination of this License shall survive.

8.0 LIMITATION OF LIABILITY.

UNDER NO CIRCUMSTANCES AND UNDER NO 
LEGAL THEORY, WHETHER IN TORT (INCLUDING 
NEGLIGENCE), CONTRACT, OR OTHERWISE, SHALL 
THE INITIAL WRITER, ANY OTHER CONTRIBUTOR, 
OR ANY DISTRIBUTOR OF DOCUMENTATION, OR 
ANY SUPPLIER OF ANY OF SUCH PARTIES, BE 
LIABLE TO ANY PERSON FOR ANY DIRECT, 
INDIRECT, SPECIAL, INCIDENTAL, OR 
CONSEQUENTIAL DAMAGES OF ANY CHARACTER 
INCLUDING, WITHOUT LIMITATION, DAMAGES FOR 
LOSS OF GOODWILL, WORK STOPPAGE, 
COMPUTER FAILURE OR MALFUNCTION, OR ANY 
AND ALL OTHER DAMAGES OR LOSSES ARISING 
OUT OF OR RELATING TO THE USE OF THE 
DOCUMENTATION, EVEN IF SUCH PARTY SHALL 
HAVE BEEN INFORMED OF THE POSSIBILITY OF 
SUCH DAMAGES.
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9.0 U.S. GOVERNMENT END USERS.

If Documentation is being acquired by or on behalf of the 
U.S. Government or by a U.S. Government prime 
contractor or subcontractor (at any tier), then the 
Government's rights in Documentation will be only as set 
forth in this Agreement; this is in accordance with 48 CFR 
227.7201 through 227.7202-4 (for Department of Defense 
(DOD) acquisitions) and with 48 CFR 2.101 and 12.212 
(for non-DOD acquisitions).

10.0 MISCELLANEOUS.

This License represents the complete agreement 
concerning the subject matter hereof. If any provision of 
this License is held to be unenforceable, such provision 
shall be reformed only to the extent necessary to make it 
enforceable. This License shall be governed by California 
law, excluding its conflict-of-law provisions. With respect to 
disputes or any litigation relating to this License, the losing 
party is responsible for costs, including without limitation, 
court costs and reasonable attorneys' fees and expenses. 
The application of the United Nations Convention on 
Contracts for the International Sale of Goods is expressly 
excluded. Any law or regulation which provides that the 
language of a contract shall be construed against the 
drafter shall not apply to this License.

Appendix

Public Documentation License Notice

The contents of this Documentation are subject to the 
Public Documentation License Version 1.0 (the 
"License"); you may only use this Documentation if you 
comply with the terms of this License. A copy of the 
License is available at 
http://www/OpenOffice.org/licenses/PDL.rtf.

The Original Documentation is _________________. 
The Initial Writer of the Original Documentation is 
______________________ (C) ____. All Rights 
Reserved. (Initial Writer 
contact(s):_______________[Insert hyperlink/alias].)

Contributor(s): 
______________________________________. 
Portions created by ______ are Copyright 
(C)_________[Insert year(s)]. All Rights Reserved. 
(Contributor contact(s):________________[Insert 
hyperlink/alias]).

Note: The text of this Appendix may differ slightly from 
the text of the notices in the files of the Original 
Documentation. You should use the text of this Appendix 
rather than the text found in the Original Documentation 
for Your Modifications.
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